読者です 読者をやめる 読者になる 読者になる

その手の平は尻もつかめるさ

ギジュツ的な事をメーンで書く予定です

バージョン 6.04 よりも古い LWP::UserAgent

バージョン 6.04 よりも古い LWP::UserAgent に delete メソッドが生えていない。少し驚いた。
古い LWP::UA 使ってると、それを継承している WWW::Mechanize とか、さらにそれを継承している Test::WWW::Mechanize とかでも delete メソッドが使えない。

大した話ではないし、もう皆さん知ってると思うけど僕は知らなかった。「なんで mech で delete が使えねのだ!!!」って感じで原因究明に結構時間かかってつらい感じだった。

結論から言うと、モジュールの Changes はよく読みましょうって感じです。
Changes 読めば一発で分かった。